New IDMETA file.
[perl-indexdata-utils.git] / libindexdata-utils-perl.spec
1 %define idmetaversion %(. ./IDMETA; echo $VERSION|tr -d '\n')
2 Summary: Utility Perl extension for Index Data applications
3 Name: libindexdata-utils-perl
4 Version: %{idmetaversion}
5 Release: 1.indexdata
6 License: IndexData
7 Group: Development/Libraries
8 Vendor: Index Data ApS <info@indexdata.com>
9 Source: libindexdata-utils-perl-%{version}.tar.gz
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-%{version}-root
12 BuildRequires: perl
13 Packager: Mike Taylor <mike@indexdata.com>
14 URL: http://www.indexdata.com/
15
16 Requires: perl-IO-File
17
18 %description
19 This library contains utility functions that we at Index Data want to
20 share between multiple applications -- for example, the persistent
21 counter used by both IRSpy and MKHome.
22
23 %prep
24 %setup
25
26 %build
27 %{__perl} Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
28 %{__make}
29
30 %install
31 %{__rm} -rf %{buildroot}
32 %{__make} pure_install DESTDIR=%{buildroot}
33 #find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
34 #find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
35 #find %{buildroot} -type f -name CPU.bs -exec rm -f {} ';'
36 # Perl's make install seems to create both uncompressed AND compressed
37 # versions of the manual pages, which confuses /usr/lib/rpm/brp-compress
38 #find $RPM_BUILD_ROOT/usr/share/man -name '*.gz' -exec rm -f '{}' \;
39
40 # Install documentation
41 DOCDIR=$RPM_BUILD_ROOT%{_datadir}/doc/libindexdata-utils-perl
42 mkdir -p $DOCDIR
43 cp -p README $DOCDIR/
44
45 %clean
46 %{__rm} -rf %{buildroot}
47
48 %files
49 %defattr(-,root,root)
50 %doc %{_datadir}/doc/libindexdata-utils-perl
51 #%doc %{_datadir}/man/man3/Masterkey::Admin::*.3pm.gz
52 %{perl_vendorlib}
53
54 %changelog
55 * Tue Dec  9 2014 Mike Taylor <mike@indexdata.com>
56 - First Red Hat packaged version.