Add %files for compressed manual pages.
[perl-indexdata-utils.git] / libindexdata-utils-perl.spec
1 %define idmetaversion %(. ./IDMETA; echo $VERSION|tr -d '\n')
2 Summary: Utility Perl extension for Index Data applications
3 Name: libindexdata-utils-perl
4 Version: %{idmetaversion}
5 Release: 1.indexdata
6 License: IndexData
7 Group: Development/Libraries
8 Vendor: Index Data ApS <info@indexdata.com>
9 Source: libindexdata-utils-perl-%{version}.tar.gz
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-%{version}-root
12 BuildRequires: perl
13 BuildRequires: perl-Test-Simple
14 Packager: Mike Taylor <mike@indexdata.com>
15 URL: http://www.indexdata.com/
16
17 Requires: perl-IO-File
18
19 %description
20 This library contains utility functions that we at Index Data want to
21 share between multiple applications -- for example, the persistent
22 counter used by both IRSpy and MKHome.
23
24 %prep
25 %setup
26
27 %build
28 %{__perl} Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
29 %{__make}
30
31 %install
32 %{__rm} -rf %{buildroot}
33 %{__make} pure_install DESTDIR=%{buildroot}
34 find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
35 #find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
36 #find %{buildroot} -type f -name CPU.bs -exec rm -f {} ';'
37
38 # Install documentation
39 DOCDIR=$RPM_BUILD_ROOT%{_datadir}/doc/libindexdata-utils-perl
40 mkdir -p $DOCDIR
41 cp -p README $DOCDIR/
42
43 %clean
44 %{__rm} -rf %{buildroot}
45
46 %files
47 %defattr(-,root,root)
48 %doc %{_datadir}/doc/libindexdata-utils-perl
49 %doc %{_datadir}/man/man3/IndexData::Utils.3pm.gz
50 %doc %{_datadir}/man/man3/IndexData::Utils::PersistentCounter.3pm.gz
51 %{perl_vendorlib}
52
53 %changelog
54 * Tue Dec  9 2014 Mike Taylor <mike@indexdata.com>
55 - First Red Hat packaged version.