2ad9dbf41f3cb291b2609e6497a35076854080ce
[perl-indexdata-utils.git] / libindexdata-utils-perl.spec
1 %define idmetaversion %(. ./IDMETA; echo $VERSION|tr -d '\n')
2 Summary: Utility Perl extension for Index Data applications
3 Name: libindexdata-utils-perl
4 Version: %{idmetaversion}
5 Release: 1.indexdata
6 License: IndexData
7 Group: Development/Libraries
8 Vendor: Index Data ApS <info@indexdata.com>
9 Source: libindexdata-utils-perl-%{version}.tar.gz
10 BuildArch: noarch
11 BuildRoot: %{_tmppath}/%{name}-%{version}-root
12 BuildRequires: perl
13 BuildRequires: perl-Test-Simple
14 Packager: Mike Taylor <mike@indexdata.com>
15 URL: http://www.indexdata.com/
16
17 Requires: perl-IO-File
18
19 %description
20 This library contains utility functions that we at Index Data want to
21 share between multiple applications -- for example, the persistent
22 counter used by both IRSpy and MKHome.
23
24 %prep
25 %setup
26
27 %build
28 %{__perl} Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
29 %{__make}
30
31 %install
32 %{__rm} -rf %{buildroot}
33 %{__make} pure_install DESTDIR=%{buildroot}
34 #find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
35 #find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
36 #find %{buildroot} -type f -name CPU.bs -exec rm -f {} ';'
37 # Perl's make install seems to create both uncompressed AND compressed
38 # versions of the manual pages, which confuses /usr/lib/rpm/brp-compress
39 #find $RPM_BUILD_ROOT/usr/share/man -name '*.gz' -exec rm -f '{}' \;
40
41 # Install documentation
42 DOCDIR=$RPM_BUILD_ROOT%{_datadir}/doc/libindexdata-utils-perl
43 mkdir -p $DOCDIR
44 cp -p README $DOCDIR/
45
46 %clean
47 %{__rm} -rf %{buildroot}
48
49 %files
50 %defattr(-,root,root)
51 %doc %{_datadir}/doc/libindexdata-utils-perl
52 #%doc %{_datadir}/man/man3/Masterkey::Admin::*.3pm.gz
53 %{perl_vendorlib}
54
55 %changelog
56 * Tue Dec  9 2014 Mike Taylor <mike@indexdata.com>
57 - First Red Hat packaged version.