configure: only consider hiredis if libgcrypt is also present
[yaz-moved-to-github.git] / configure.ac
index dd4385a..887ba56 100644 (file)
@@ -1,11 +1,14 @@
 dnl This file is part of the YAZ toolkit.
 dnl This file is part of the YAZ toolkit.
-dnl Copyright (C) 1995-2011 Index Data
+dnl Copyright (C) Index Data
+dnl See the file LICENSE for details.
 AC_PREREQ([2.60])
 AC_PREREQ([2.60])
-AC_INIT([yaz],[4.2.18],[yaz-help@indexdata.dk])
+AC_INIT([yaz],
+m4_esyscmd([. ./IDMETA; echo $VERSION|tr -d '\n']),
+[yaz-help@indexdata.dk])
 AC_CONFIG_HEADERS(include/config.h)
 AC_CONFIG_SRCDIR([configure.ac])
 AC_CONFIG_AUX_DIR([config])
 AC_CONFIG_HEADERS(include/config.h)
 AC_CONFIG_SRCDIR([configure.ac])
 AC_CONFIG_AUX_DIR([config])
-AM_INIT_AUTOMAKE([1.9])
+AM_INIT_AUTOMAKE([1.11.1 subdir-objects])
 dnl
 AC_SUBST([READLINE_LIBS])
 AC_SUBST([YAZ_CONF_CFLAGS])
 dnl
 AC_SUBST([READLINE_LIBS])
 AC_SUBST([YAZ_CONF_CFLAGS])
@@ -20,7 +23,7 @@ AM_PROG_LIBTOOL
 AC_PATH_PROG([pkgconfigpath],[pkg-config],[NONE])
 dnl
 YAZ_DOC
 AC_PATH_PROG([pkgconfigpath],[pkg-config],[NONE])
 dnl
 YAZ_DOC
-dnl 
+dnl
 dnl
 AC_CHECK_HEADERS([dirent.h fnmatch.h wchar.h locale.h langinfo.h pwd.h unistd.h sys/select.h sys/socket.h sys/stat.h sys/time.h sys/times.h sys/types.h sys/un.h sys/wait.h sys/prctl.h netdb.h arpa/inet.h netinet/tcp.h netinet/in_systm.h],[],[],[])
 AC_CHECK_HEADERS([net/if.h netinet/in.h netinet/if_ether.h],[],[],[
 dnl
 AC_CHECK_HEADERS([dirent.h fnmatch.h wchar.h locale.h langinfo.h pwd.h unistd.h sys/select.h sys/socket.h sys/stat.h sys/time.h sys/times.h sys/types.h sys/un.h sys/wait.h sys/prctl.h netdb.h arpa/inet.h netinet/tcp.h netinet/in_systm.h],[],[],[])
 AC_CHECK_HEADERS([net/if.h netinet/in.h netinet/if_ether.h],[],[],[
@@ -56,77 +59,103 @@ if test "$checkBoth" = "1"; then
     AC_CHECK_FUNC([accept], , [LIBS=$oldLibs])
 fi
 AC_CHECK_FUNC([gethostbyname], ,[AC_CHECK_LIB(nsl, main, [LIBS="$LIBS -lnsl"])])
     AC_CHECK_FUNC([accept], , [LIBS=$oldLibs])
 fi
 AC_CHECK_FUNC([gethostbyname], ,[AC_CHECK_LIB(nsl, main, [LIBS="$LIBS -lnsl"])])
-dnl
-
-dnl ------ OpenSSL
-AC_SUBST([SSL_CFLAGS])
-AC_SUBST([SSL_LIBS])
-openssl=no
-sslver=no
-AC_ARG_WITH([openssl], [  --with-openssl[=PREFIX]   OpenSSL library in PREFIX], [openssl=$withval])
-SSL_CFLAGS=""
-SSL_LIBPATH=""
-if test "$openssl" != "no"; then
-    if test "$openssl" != "yes" -a "$openssl" != "default"; then
-       if test -x $openssl/bin/pkg-config; then
-           if $openssl/bin/pkg-config --exists openssl; then
-               SSL_CFLAGS=`$openssl/bin/pkg-config --cflags openssl`
-               SSL_LIBS="`$openssl/bin/pkg-config --libs openssl`"
-               sslver=`$openssl/bin/pkg-config --modversion openssl`
-           fi
-       fi
-       if test "$sslver" = "no"; then
-           SSL_CFLAGS="-I$openssl/include -I$openssl/include/openssl"
-           SSL_LIBPATH="-L$openssl/lib"
-       fi
+dnl ------ libgcrypt
+AC_SUBST([GCRYPT_LIBS])
+libgcryptpath=NONE
+AC_ARG_WITH(libgcrypt, [  --with-libgcrypt=DIR    use libgcrypt-config in DIR],[libgcryptpath=$withval])
+if test "$libgcryptpath" != "no"; then
+    if test "$libgcryptpath" = "NONE"; then
+       AC_PATH_PROG([libgcrypt],[libgcrypt-config],[NONE])
+    elif test -x $libgcryptpath/libgcrypt-config; then
+       libgcrypt=$libgcryptpath/libgcrypt-config
     else
     else
-       if test "$pkgconfigpath" != "NONE"; then
-           if $pkgconfigpath --exists openssl; then
-               SSL_CFLAGS=`$pkgconfigpath --cflags openssl`
-               SSL_LIBS="`$pkgconfigpath --libs openssl`"
-               sslver=`$pkgconfigpath --modversion openssl`
+       libgcrypt=$libgcryptpath
+    fi
+    AC_MSG_CHECKING([for libgcrypt])
+    if "$libgcrypt" --version >/dev/null 2>&1; then
+       libgcryptversion=`$libgcrypt --version`
+       libgcryptversion2=`echo "$libgcryptversion" | awk 'BEGIN { FS = "."; } { printf "%d", [$]1 * 1000 + [$]2;}'`
+       AC_MSG_RESULT([$libgcryptversion])
+       if test $libgcryptversion2 -ge 1002; then
+           GCRYPT_LIBS="`$libgcrypt --libs`"
+           CFLAGS="$CFLAGS `$libgcrypt --cflags`"
+           AC_DEFINE([HAVE_GCRYPT_H],[1],[Define to 1 if libgcrypt is present])
+       else
+           if test "$libgcryptpath" = "NONE"; then
+               AC_MSG_WARN([Only libgcrypt version 1.2 and later supported])
+           else
+               AC_MSG_ERROR([Only libgcrypt version 1.2 and later supported])
            fi
            fi
+           libgcryptversion=""
        fi
        fi
-       if test "$sslver" = "no"; then
-           SSL_CFLAGS="-I/usr/include/openssl"
-       fi
+    else
+       AC_MSG_RESULT([no])
     fi
     fi
-    if test "$sslver" = "no"; then
-       xLIBS="$LIBS";
-       xCPPFLAGS="$CPPFLAGS";
-       CPPFLAGS="$CPPFLAGS ${SSL_CFLAGS} ${SSL_LIBPATH}"
-       SSL_LIBS="${SSL_LIBPATH}"
-       AC_CHECK_LIB([crypto],[main])
-       if test "$ac_cv_lib_crypto_main" = "yes"; then
-           SSL_LIBS="${SSL_LIBS} -lcrypto"
-       fi
-       AC_CHECK_LIB([ssl],[SSL_new])
-       if test "$ac_cv_lib_ssl_SSL_new" = "yes"; then
-           AC_CHECK_HEADER([openssl/ssl.h],[sslver=yes])
-           SSL_LIBS="${SSL_LIBS} -lssl"
+fi
+dnl ------ redis
+hiredis=default
+AC_SUBST([HIREDIS_LIBS])
+AC_ARG_WITH([redis], [  --with-redis        hiredis library], [hiredis=$withval])
+if test "$hiredis" != "no" -a "$pkgconfigpath" != "NONE" -a "$libgcryptversion"; then
+    AC_CHECK_LIB([hiredis],[redisCommandArgv],[HIREDIS_LIBS=-lhiredis])
+    AC_MSG_CHECKING([for redis])
+    if $pkgconfigpath --cflags hiredis >/dev/null 2>&1 ; then
+       if $pkgconfigpath --atleast-version 0.10 hiredis; then
+           AC_MSG_RESULT([yes])
+            CFLAGS="$CFLAGS `$pkgconfigpath --cflags hiredis`"
+            HIREDIS_LIBS="`$pkgconfigpath --libs hiredis`"
+           AC_DEFINE([HAVE_HIREDIS],[1],[Define to 1 if hiredis is enabled])
+       else
+           AC_MSG_RESULT([no. Version 0.10 required])
+            if test "$hiredis" != "default"; then
+               AC_MSG_ERROR([hiredis libraries missing])
+            fi
        fi
        fi
-       if test "$sslver" != "yes"; then
-           SSL_LIBS=""
+    else
+       if test "$ac_cv_lib_hiredis_redisCommandArgv" = "yes"; then
+           AC_DEFINE([HAVE_HIREDIS],[1])
+           AC_MSG_RESULT([yes])
+       else
+           AC_MSG_RESULT([no])
+            if test "$hiredis" != "default"; then
+               AC_MSG_ERROR([hiredis libraries missing])
+           fi
        fi
        fi
-        LIBS="$xLIBS"
-       CPPFLAGS="$xCPPFLAGS"
     fi
     fi
-    AC_MSG_CHECKING([for SSL])
-    if test "$sslver" != "no"; then
-       AC_DEFINE([HAVE_OPENSSL_SSL_H],[1],[Define to 1 if OpenSSL is present])
-       AC_MSG_RESULT([$sslver])
+fi
+dnl ------ memcached
+memcached=default
+AC_SUBST([MEMCACHED_LIBS])
+AC_ARG_WITH([memcached], [  --with-memcached        Memcached library], [memcached=$withval])
+if test "$memcached" != "no" -a -n "$libgcryptversion" -a "$pkgconfigpath" != "NONE"; then
+    AC_MSG_CHECKING([for libmemcached])
+    if $pkgconfigpath --cflags libmemcached >/dev/null 2>&1 ; then
+       if $pkgconfigpath --atleast-version 1.0 libmemcached; then
+           AC_MSG_RESULT([yes])
+            CFLAGS="$CFLAGS `$pkgconfigpath --cflags libmemcached`"
+            MEMCACHED_LIBS="`$pkgconfigpath --libs libmemcached`"
+           AC_DEFINE([HAVE_LIBMEMCACHED_MEMCACHED_H],[1],[Define to 1 if memcached header])
+           AC_DEFINE([HAVE_MEMCACHED_FUNC],[1],[Define to 1 if memcached function  is defined])
+           AC_DEFINE([HAVE_MEMCACHED_RETURN_T],[1],[Define to 1 if memcached_return_t is defined])
+        else
+           AC_MSG_RESULT([no. Version 1.0 required])
+            if test "$memcached" != "default"; then
+               AC_MSG_ERROR([libmemcached  libraries missing])
+            fi
+        fi
     else
     else
-       SSL_CFLAGS=""
-       AC_MSG_RESULT([None])
-       if test "$openssl" != "default"; then
-           AC_MSG_ERROR([OpenSSL development libraries missing])
+       AC_MSG_RESULT([no])
+        if test "$memcached" != "default"; then
+           AC_MSG_ERROR([libmemcached  libraries missing])
        fi
     fi
 fi
 dnl ------ GNU TLS
        fi
     fi
 fi
 dnl ------ GNU TLS
+AC_SUBST([SSL_CFLAGS])
+AC_SUBST([SSL_LIBS])
 gnutls=default
 AC_ARG_WITH([gnutls], [  --with-gnutls[=PREFIX]    GNU TLS library in PREFIX], [gnutls=$withval])
 gnutls=default
 AC_ARG_WITH([gnutls], [  --with-gnutls[=PREFIX]    GNU TLS library in PREFIX], [gnutls=$withval])
-if test "$gnutls" != "no" -a "$sslver" = "no"; then
+if test "$gnutls" != "no"; then
     gnutlsver=no
     if test "$gnutls" != "yes" -a "$gnutls" != "default"; then
        if test -x $gnutls/bin/pkg-config; then
     gnutlsver=no
     if test "$gnutls" != "yes" -a "$gnutls" != "default"; then
        if test -x $gnutls/bin/pkg-config; then
@@ -321,8 +350,8 @@ if test "$enable_threads" = "yes" -a "$HAVETHREADS" = "0"; then
     ACX_PTHREAD([
            OCFLAGS=$CFLAGS
            CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
     ACX_PTHREAD([
            OCFLAGS=$CFLAGS
            CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
-           dnl unfortunately empty thread lib spec is problematic because 
-            dnl 'yaz-config --cflags' is not always passed to linker in 
+           dnl unfortunately empty thread lib spec is problematic because
+            dnl 'yaz-config --cflags' is not always passed to linker in
             dnl applications using YAZ (such as Zebra).
            if test "x$PTHREAD_LIBS" = "x"; then
                OLIBS=$LIBS
             dnl applications using YAZ (such as Zebra).
            if test "x$PTHREAD_LIBS" = "x"; then
                OLIBS=$LIBS
@@ -360,7 +389,7 @@ if test "$xml_enabled" = "true"; then
            AC_DEFINE(YAZ_HAVE_EXSLT,1,[Define to 1 if EXSLT is present])
            YAZ_CONFIG_CFLAGS="$YAZ_CONFIG_CFLAGS -DYAZ_HAVE_EXSLT=1"
        ])
            AC_DEFINE(YAZ_HAVE_EXSLT,1,[Define to 1 if EXSLT is present])
            YAZ_CONFIG_CFLAGS="$YAZ_CONFIG_CFLAGS -DYAZ_HAVE_EXSLT=1"
        ])
-    
+
 fi
 YAZ_CONFIG_CFLAGS="$YAZ_CONFIG_CFLAGS $XML2_CFLAGS"
 
 fi
 YAZ_CONFIG_CFLAGS="$YAZ_CONFIG_CFLAGS $XML2_CFLAGS"
 
@@ -369,7 +398,7 @@ if test "$XML2_LIBS"; then
 fi
 
 dnl
 fi
 
 dnl
-dnl 
+dnl
 AC_CHECK_ICU([3.4],[
        if test "$xml_enabled" = "true"; then
            ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
 AC_CHECK_ICU([3.4],[
        if test "$xml_enabled" = "true"; then
            ICU_CPPFLAGS="$ICU_CPPFLAGS -D YAZ_HAVE_ICU=1"
@@ -404,7 +433,7 @@ client/Makefile
 ztest/Makefile
 zoom/Makefile
 doc/Makefile
 ztest/Makefile
 zoom/Makefile
 doc/Makefile
-doc/local.ent
+doc/local0.ent
 doc/common/Makefile
 doc/common/print.dsl
 etc/Makefile
 doc/common/Makefile
 doc/common/print.dsl
 etc/Makefile
@@ -415,6 +444,8 @@ win/version.nsi
 include/yaz/yaz-version.h
 ],[
        sed s%echo_source=yes%echo_source=no%g < yaz-config > util/yaz-config && chmod +x yaz-config util/yaz-config
 include/yaz/yaz-version.h
 ],[
        sed s%echo_source=yes%echo_source=no%g < yaz-config > util/yaz-config && chmod +x yaz-config util/yaz-config
+       diff doc/local.ent doc/local0.ent >/dev/null 2>/dev/null \
+               || cp doc/local0.ent doc/local.ent
     ]
 )
 
     ]
 )