rules changed to obey version 4 compatability
[tclrobot.git] / debian / rules
index 6924226..9e34ee6 100755 (executable)
@@ -5,6 +5,14 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+# Force compat level four
+export DH_COMPAT=4
+
+# Ignore CVS information
+export DH_ALWAYS_EXCLUDE=CVS
+
+# This has to be exported to make some magic below work.
+#export DH_OPTIONS
 
 
 
@@ -63,8 +71,7 @@ install: build
 
        # Add here commands to install the package into debian/tmp
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
-       #cp tclrobot.so debian/tmp/usr/lib/libtclrobot.so
-
+       dh_install
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -77,7 +84,7 @@ binary-arch: build install
        dh_installchangelogs 
        dh_installdocs
 #      dh_installexamples
-       dh_install
+#      dh_install maybe wrong place here?? moved to 
 #      dh_installmenu
 #      dh_installdebconf       
 #      dh_installlogrotate