Build requires yaz. Updated package version so that it is clear that
[simpleserver-moved-to-github.git] / INSTALL
1 Building and installation
2 -------------------------
3
4
5 1. Requirements
6
7 The Net::Z3950::SimpleServer Perl module requires the YAZ toolkit: the
8 development version 1.7 or any subsequent version is fine. You can
9 download it via this link,
10
11         http://ftp.indexdata.dk/pub/yaz/development/
12
13 You need to configure the YAZ toolkit with the command
14
15         % ./configure --enable-shared
16
17 Then compile and install
18
19         % make
20         # make install
21
22 You don't *need* to install YAZ globally on your machine if you
23 prefer not to. In this case, you just have to update the Makefile.PL
24 with the locations of the libraries.
25
26 2. Installation
27
28 Unpack the tar ball this way
29
30         % gunzip Net-Z3950-SimpleServer-xxxx.tar.gz
31         % tar xvf Net-Z3950-SimpleServer-xxxx.tar.gz
32
33 and cd to the root directory of the module package
34
35         % cd Net-Z3950-SimpleServer-xxxx
36
37 The installation takes place by issuing the following commands:
38
39         % perl Makefile.PL
40         % make
41         % make test
42         # make install
43
44 The last command has to be issued as super user.
45
46 Good luck!
47
48 Anders S√łnderberg <sondberg@indexdata.dk>
49 http://www.indexdata.dk/
50
51
52