@syntax made global.
[irspy-moved-to-github.git] / Makefile.PL
1
2 use 5.008;
3 use strict;
4 use warnings;
5 use ExtUtils::MakeMaker;
6
7 my $yazver = `yaz-config --version`;
8 if (!$yazver) {
9     die qq[
10 ERROR: Unable to call script: yaz-config
11 If you are using a YAZ installation from the Debian package "yaz", you
12 will also need to install "libyaz-dev" in order to build this module.
13 ];
14 }
15
16 chomp($yazver);
17 # 2.1.53 is the first version with ZOOM-C fixed to properly support
18 # reconnection in asynchronous mode.
19 check_version($yazver, "2.1.53");
20
21 # See lib/ExtUtils/MakeMaker.pm for details of how to influence
22 # the contents of the Makefile that is written.
23 WriteMakefile(
24     NAME              => 'ZOOM::IRSpy',
25     VERSION_FROM      => 'lib/ZOOM/IRSpy.pm', # finds $VERSION
26     PREREQ_PM         => {
27         "Net::Z3950::ZOOM" => 1.19,
28         "XML::LibXML::XPathContext" => 0.07, # For Web UI
29         "XML::LibXML" => 1.58,
30         "XML::LibXSLT" => 1.57,
31         "URI::Escape" => 3.28, # For Web UI
32     },
33     ($] >= 5.005 ?     ## Add these new keywords supported since 5.005
34       (ABSTRACT_FROM  => 'lib/ZOOM/IRSpy.pm', # retrieve abstract from module
35        AUTHOR         => 'Mike Taylor <mike@indexdata.com>') : ()),
36 );
37
38
39 sub check_version {
40     my($got, $want) = @_;
41
42     my($gmajor, $gminor, $gtrivial) = ($got =~ /(\d+)\.(\d+)\.(\d+)/);
43     my($wmajor, $wminor, $wtrivial) = ($want =~ /(\d+)\.(\d+)\.(\d+)/);
44     if (($gmajor < $wmajor) ||
45         ($gmajor == $wmajor && $gminor < $wminor) ||
46         ($gmajor == $wmajor && $gminor == $wminor && $gtrivial < $wtrivial)) {
47         print <<__EOT__;
48 *** ERROR!
49 ZOOM-Perl requires at least version $want of YAZ,
50 but is currently you only have version $got.
51 __EOT__
52         exit 1;
53     }
54 }